Red Hat has transformed CentOS into CentOS Stream, a rolling-release Linux distribution. Top European Linux distributor SUSE has gone the other way. Its latest SUSE Linux Enterprise Server (SLES) 15 SP3 release comes with full binary compatibility between its community Linux distribution, openSUSE Leap, and SLES.

This means that if you’re already using openSUSE Leap you can easily migrate up to SLES 15 SP3 for your corporate Linux desktop or server work. SUSE will continue to offer its rolling-release distro, openSUSE Tumbleweed. Tumbleweed can also be thought of as the beta for Leap and SLES.

SUSE is making this “Closing the Leap Gap” to increase compatibility and to leverage synergies between the community and the enterprise version. This move isn’t meant to over-rule the community. It’s to empower it by offering pre-made binaries and bringing the two SUSE source code streams into harmony with each other.

That’s not to say that openSUSE Leap and SLES will be identical. For example, architecturally they won’t support quite the same platforms. So while both SLES and Leap will support: aarch64, x86-64, ppc64le, and s390x, only Leap, for now, will support RISC-V and ARMv7.

As you might guess from this development SUSE is encouraging users to migrate from openSUSE to SLES. SUSE, aware that many CentOS users are looking for a new enterprise Linux home, will soon release programs and services to help CentOS users migrate to Leap.

This SLES update also introduces SUSE Linux Enterprise Base Container Images (SLE BCI). These provide open, flexible, and secure container images and application development tools for developers and integrators. This will be released in a hardened and certified version for regulated markets. On Leap and SLES, these run using Podman, Pod Manager Tool. This drop-in alternative for Docker is a daemon less container engine for developing, managing, and running Open Container Initiative (OCI) containers.

Under the hood, SLES runs on the 5.3.18-46.1 Linux kernel. Above that, you’ll find updates to the most popular programming languages and applications. For example, SLES 15 SP3 supports the MariaDB 10.5 and PostgreSQL 13 databases. PostgreSQL 12, however, will still be available via Legacy Module for migration.

Business users should note that SLES 15 has a 13-year life cycle, with 10 years of General Support and three years of Extended Support. The current version (SP3) will be fully maintained and supported until six months after the release of the SLES 15 SP4. SLES 15 SP3 will be released later this summer, so you’ll be able to use it until approximately December 2022.

Tags: , , , , , , , , , , , , , , , , , , , , , , , , , , ,